Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Michael Kluskens (mkluskens_at_[hidden])
Date: 2006-05-02 18:05:21


My test codes compile fine but I'm fairly certain the logical is
being handled incorrectly. When I merge two comm's with one having
high=.false. and the other high=.true., the latter should go into the
higher ranks and the former should contain rank 0.

I'll work it over again tomorrow and see if I can create an f77
version or use the mpi.h file and see if I can get a clear difference
and I'll compare against MPICH2 but someone else should look into
this issue.

Michael

On May 1, 2006, at 11:57 PM, Jeff Squyres (jsquyres) wrote:

> I just fixed the INTERCOMM_MERGE/logical issue on the trunk and the
> v1.1
> branch -- can you give it a whirl there?
>
> I ask because this issue is a bug that we fixed on the trunk (and
> therefore v1.1) and didn't back-port it to v1.0. There's actually
> quite
> a few of these F90 fixes on the trunk/v1.1 branch that we did not
> back-port to v1.0 (e.g., most of the other logical fixes) mainly
> because
> we thought you were the main consumer of the F90 MPI API (and
> therefore
> it wasn't worth it to back port :-) ). If you need all these fixes in
> v1.0, we can spend the time to do the back-port, but would prefer
> not to
> if possible.
>
>
>> -----Original Message-----
>> From: users-bounces_at_[hidden]
>> [mailto:users-bounces_at_[hidden]] On Behalf Of Michael Kluskens
>> Sent: Monday, May 01, 2006 6:20 PM
>> To: Open MPI Users
>> Subject: [OMPI users] openmpi-1.0.2 configure problem
>>
>> checking if FORTRAN compiler supports integer(selected_int_kind
>> (2))... yes
>> checking size of FORTRAN integer(selected_int_kind(2))... unknown
>> configure: WARNING: *** Problem running configure test!
>> configure: WARNING: *** See config.log for details.
>> configure: error: *** Cannot continue.
>>
>> Source code: openmpi-1.0.2 stable
>> OS X 10.4.5 with g95 (Apr 27 2006)
>> ./configure F77=g95 FC=g95 LDFLAGS=-lSystemStubs
>>
>> I find this rather surprising given that I have been regularly
>> building nightly snapshots of Open MPI 1.1 and 1.2 (the other bug is
>> preventing me from using them at the moment till either I change my
>> code or the bugs gets fixed).
>>
>>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>