Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

From: Dries Kimpe (Dries.Kimpe_at_[hidden])
Date: 2006-05-02 16:32:56


  Hi,

are there any known problems with Open MPI (SVN rev. 9792) and Parallel
NetCDF (version 1.0.1)?

I'm unable to make this combination work.
The tests distributed with the source of pnetcdf fail when building with
Open MPI.

It looks as if the problem is not really due to Open MPI, but to the
included ROM-IO:

All tests fail with the same error message:

For example, test/test_double/test_write shows:

Testing write ... Error: Unsupported datatype passed to
ADIOI_Count_contiguous_blocks
[lts.mydomain.be:26763] [0,0,0] ORTE_ERROR_LOG: Not found in file
../../../../orte/mca/pls/base/pls_base_proxy.c at line 189

They do work with mpich2 (1.0.3).

I didn't try updating the version of ROM-IO included in the Open MPI SVN
repository [yet].

   Greetings,
   Dries

PS. pnetcdf also doesn't build with the lam 7.1.1, because of a missing
MPI_Request_get_status implementation.

Disclaimer: http://www.kuleuven.be/cwis/email_disclaimer.htm