Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Brian Barrett (brbarret_at_[hidden])
Date: 2006-04-16 17:17:27


On Apr 16, 2006, at 2:10 PM, Lee D. Peterson wrote:

> The firewires are all inactive. The only difference from ipconfig
> is that the cluster head has a ppp0 defined because of a VPN I'm
> using. I tried -mac btl_tcp_if_exclude ppp0, but that didn't work.
>
> So I logged off the VPN, and now ifconfig -a on the cluster head
> does not show the ppp0. However, everything is now fixed: I can use
> mpiexec without the MCA declaration.

That's very strange. I can say with almost absolute certainty that
we never tried that configuration ;). I'm away from our cluster
resources this week and don't want to mess with the networking from
1500 miles away, but when I get back, I'll see if I can duplicate
your problem. Also very strange that excluding the device didn't fix
the problem.

In the mean time, you can probably get away with setting the MCA
parameter in the system configuration file to include en0 and en1 to
avoid potential VPN interaction. More on setting MCA parameters is
available from our FAQ:

   http://www.open-mpi.org/faq/?category=sysadmin#sysadmin-mca-params

Hope this helps,

Brian

-- 
   Brian Barrett
   Open MPI developer
   http://www.open-mpi.org/