Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Brian Barrett (brbarret_at_[hidden])
Date: 2006-04-14 11:51:45


On Apr 12, 2006, at 7:19 PM, Jorge Parra wrote:

> I am trying to configure openmpi-1.0.2. However it gives me an
> error while running the configuration step. It stops when
> trying to determine the "aligment of bool". I attached the outputs
> as it is suggested.
>
> The system I am using to build openmpi is an intel P4 running
> RedHat Enterprise 3. I am using it to crosscompile for a
> system running a power pc 405, and montavista linux 3.1 over it.

It appears that this is an issue with our configure tests with more
recent versions of GCC and cross-compiling (the error will not occur
when not cross compiling). Fixes have been applied for all the
upcoming releases. You can grab a nightly release from the 1.0
branch tomorrow and it should work. The nightly tarballs can be
downloaded from:

   http://www.open-mpi.org/nightly/v1.0/

Releases from the 1.0 series will not properly cross-compile the
Fortran bindings - they must explicitly be disabled with --disable-
mpi-f77 in order for the configure script to complete. ROMIO on the
1.0 series has also not been tested to make sure it properly cross-
compiles. This has been fixed for the upcoming 1.1 release, although
you will have to run an external program on the target platform in
order to generate a seed file for some of the data we need in order
to cross-compile our Fortran bindings. We don't have documentation
on this just yet, but I can provide you with instructions if you need
Fortran bindings.

Hope this helps,

Brian

-- 
   Brian Barrett
   Open MPI developer
   http://www.open-mpi.org/