Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Jeff Squyres \(jsquyres\) (jsquyres_at_[hidden])
Date: 2006-04-12 23:03:57


My mistake -- I missed the "orted" part of the error message.

"orted" is a helper application that is intentally launched by Open MPI
during mpirun. What is happening is that it is not able to find the
Intel libraries, and is therefore failing to launch.

So why is it not finding the Intel shared library?

- is this error message coming from a remote node?
- is your LD_LIBRARY_PATH set for all your remote nodes? For example,
if you're using rsh or ssh to start processes (vs. a resource manager
such as SLURM or Torque), you will need to ensure that your shell
startup files on all the nodes sets LD_LIBRARY_PATH properly (i.e., it's
not enough to "setenv LD_LIBRARY_PATH ...; mpirun ..." because the
LD_LIBRARY_PATH value won't be set on all the nodes)
- Is the Intel shared library available on all your nodes? (you didn't
specify if the applications that you are able to run were on all your
compute nodes or just on the node where you compiled them)
 

> -----Original Message-----
> From: Aniruddha Shet [mailto:shet_at_[hidden]]
> Sent: Wednesday, April 12, 2006 12:17 PM
> To: Open MPI Users
> Cc: Jeff Squyres (jsquyres)
> Subject: Re: [OMPI users] Error while loading shared libraries
>
> Hi,
>
> I am able to run non-OpenMPI MPI jobs where the MPI library
> is built on top
> of Intel compilers. Plus, non-MPI jobs built with Intel
> compilers run just
> fine. So, I am not sure how to go about fixing this.
>
> Thanks,
> Aniruddha
>
> ----- Original Message -----
> From: "Jeff Squyres (jsquyres)" <jsquyres_at_[hidden]>
> To: "Open MPI Users" <users_at_[hidden]>
> Sent: Wednesday, April 12, 2006 8:30 AM
> Subject: Re: [OMPI users] Error while loading shared libraries
>
>
> > Greetings.
> >
> > Your logs look normal.
> >
> > The problem appears to be how you compiled / linked your final
> > executable. You said that you used -static -- I don't know
> offhand if
> > that is a supported flag for the intel compiler or not.
> Did you *link*
> > with -static, or just *compile* with it?
> >
> > Try running "ldd" on your executable -- it will show which shared
> > libraries your executable links against.
> >
> > I *think* that libcprts.so is a library internal to the
> Inter compiler
> > -- so even if icc supports "-static", this library may be
> exempted...?
> > (that's a total guess -- I'm not familiar with the internals of the
> > Intel compilers) If this is the case, you might try installing the
> > Intel compiler run-time libraries on all your nodes (this seems
> > unattractive, though).
> >
> > Regardless, I don't think that this is an MPI problem --
> you might want
> > to try playing around with compiling some simple [non-MPI]
> "hello world"
> > applications with your Intel compiler to figure out how to compile
> > things statically.
> >
> >
> > > -----Original Message-----
> > > From: users-bounces_at_[hidden]
> > > [mailto:users-bounces_at_[hidden]] On Behalf Of Aniruddha Shet
> > > Sent: Monday, April 10, 2006 10:06 PM
> > > To: users_at_[hidden]
> > > Subject: [OMPI users] Error while loading shared libraries
> > >
> > > Hi,
> > >
> > > I have built OpenMPI using ifort and icc Intel compilers
> > > with --enable-static --disable-shared options. I compile
> my job using
> > > OpenMPI wrapper compilers, additionally with -static option.
> > > When I run the
> > > job, I get the error 'orted:error while loading shared libraries:
> > > libcprts.so.5: cannot open shared object file: No such file
> > > or directory'. I
> > > also have the path of Intel compiler libraries in
> > > LD_LIBRARY_PATH. Please
> > > find attached a tar file having config.log and ompi_info output.
> > >
> > > Thanks,
> > > Aniruddha
> > > --------------------------------------------------------------
> > > --------------------
> > > Aniruddha Shet | Project webpage:
> > > http://forge-fre.ornl.gov/molar/index.html
> > > Graduate Research Associate | Project webpage:
> www.cs.unm.edu/~fastos
> > > Dept. of Comp. Sci. & Engg | Personal webpage:
> > > www.cse.ohio-state.edu/~shet
> > > The Ohio State University | Office: DL 474
> > > 2015 Neil Avenue | Phone: +1 (614) 292 7036
> > > Columbus OH 43210-1277 | Cell: +1 (614) 446 1630
> > > --------------------------------------------------------------
> > > --------------------
> > >
> >
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
> >
> >
>