Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Ralph Castain (rhc_at_[hidden])
Date: 2006-04-11 11:32:15


Thanks Michael - we're looking into it and will get back to you shortly.

Ralph


Michael Kluskens wrote:
On Apr 10, 2006, at 6:31 PM, Ralph Castain wrote:

  
Was this the only output you received? If so, then it looks like  
your parent process never gets to spawn and bcast - you should have  
seen your write statements first, yes?

Ralph
    

I only listed the ORTE errors, I get the correct output, complete as  
follows:

parent:  0  of  1
parent: How many processes total?
2
parent: Calling MPI_Comm_spawn to start  1  subprocesses.
parent: Calling MPI_BCAST with btest =  17 .  child =  3
child 0 of 1:  Parent 3
[host:00258] [0,0,0] ORTE_ERROR_LOG: Not found in file base/ 
soh_base_get_proc_soh.c at line 80
[host:00258] [0,0,0] ORTE_ERROR_LOG: Not found in file base/ 
oob_base_xcast.c at line 108
[host:00258] [0,0,0] ORTE_ERROR_LOG: Not found in file base/ 
rmgr_base_stage_gate.c at line 276
[host:00258] [0,0,0] ORTE_ERROR_LOG: Not found in file base/ 
soh_base_get_proc_soh.c at line 80
[host:00258] [0,0,0] ORTE_ERROR_LOG: Not found in file base/ 
oob_base_xcast.c at line 108
[host:00258] [0,0,0] ORTE_ERROR_LOG: Not found in file base/ 
rmgr_base_stage_gate.c at line 276
child 0 of 1:  Receiving   17 from parent
Maximum user memory allocated: 0

Michael


  
Michael Kluskens wrote:
    
The ORTE errors again, these are new and different errors.  Tested  
as of  OpenMPI 1.1a1r9596.

[host:10198] [0,0,0] ORTE_ERROR_LOG: Not found in file base/ 
soh_base_get_proc_soh.c at line 80
[host:10198] [0,0,0] ORTE_ERROR_LOG: Not found in file base/ 
oob_base_xcast.c at line 108
[host:10198] [0,0,0] ORTE_ERROR_LOG: Not found in file base/ 
rmgr_base_stage_gate.c at line 276
[host:10198] [0,0,0] ORTE_ERROR_LOG: Not found in file base/ 
soh_base_get_proc_soh.c at line 80
[host:10198] [0,0,0] ORTE_ERROR_LOG: Not found in file base/ 
oob_base_xcast.c at line 108
[host:10198] [0,0,0] ORTE_ERROR_LOG: Not found in file base/ 
rmgr_base_stage_gate.c at line 276

This test was run using OpenMPI 1.1 built on OS X 10.4.6 with g95  
from 4/9/06.  Past experience was that the ORTE errors were  
independent of OS and compiler.  Attached sample codes generated  
these errors.  They use MPI_SPAWN and MPI_BCAST (most vendors  
MPI's can't run this test case).
      
_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users