Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Charles Williams (willic3_at_[hidden])
Date: 2006-04-10 11:25:48


Hi,

I have been attempting to build OpenMPI on my Mac, using the older
gcc-3.3 compiler using rc2r9567. Things proceed for a while, and
then I get:

Making all in xgrid
/Users/willic3/build/openmpi-buildgcc3.3/orte/dynamic-mca/pls/xgrid
depbase=`echo src/pls_xgrid_component.lo | sed 's|[^/]*$|.deps/&|;s|
\.lo$||'`; \
if /bin/sh ../../../../libtool --mode=compile gcc -DHAVE_CONFIG_H -I.
-I/Users/willic3/build/openmpi-1.0.2rc2r9567/orte/mca/pls/xgrid -
I../../../../include -I../../../../include -I/Users/willic3/build/
openmpi-buildgcc3.3/include -I/Users/willic3/build/
openmpi-1.0.2rc2r9567/include -I/Users/willic3/build/
openmpi-1.0.2rc2r9567 -I../../../.. -I../../../../include -I/Users/
willic3/build/openmpi-1.0.2rc2r9567/opal -I/Users/willic3/build/
openmpi-1.0.2rc2r9567/orte -I/Users/willic3/build/
openmpi-1.0.2rc2r9567/ompi -D_REENTRANT -F XGridFoundation -MT src/
pls_xgrid_component.lo -MD -MP -MF "$depbase.Tpo" -c -o src/
pls_xgrid_component.lo /Users/willic3/build/openmpi-1.0.2rc2r9567/
orte/mca/pls/xgrid/src/pls_xgrid_component.m; \
then mv -f "$depbase.Tpo" "$depbase.Plo"; else rm -f "$depbase.Tpo";
exit 1; fi
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
make[4]: *** [src/pls_xgrid_component.lo] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive] Error 1

I may be able to avoid this problem by building without xgrid (I'm
going to try that now), but does anyone have any ideas on other
solutions? I've built the code successfully using the default Tiger
compilers.

Thanks,
Charles

Machine info:

uname -a
Darwin rachel.geo.rpi.edu 8.6.0 Darwin Kernel Version 8.6.0: Tue Mar
7 16:58:48 PST 2006; root:xnu-792.6.70.obj~1/RELEASE_PPC Power
Macintosh powerpc

gcc-3.3 --version
gcc-3.3 (GCC) 3.3 20030304 (Apple Computer, Inc. build 1819)

I configured and built after using 'gcc_select 3.3'.

Configure command:
/Users/willic3/build/openmpi-1.0.2rc2r9567/configure --prefix=/Users/
willic3/geo
frame/tools/openmpi-gcc3.3 --disable-mpi-f90

I can also provide the configure and build logs if that will help.

Charles A. Williams
Dept. of Earth & Environmental Sciences
Science Center, 2C01B
Rensselaer Polytechnic Institute
Troy, NY 12180
Phone: (518) 276-3369
FAX: (518) 276-2012
e-mail: willic3_at_[hidden]