Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Francoise Roch (roch_at_[hidden])
Date: 2006-04-04 07:38:41


Jeff Squyres (jsquyres) wrote:
> Doh!
>
> This is a problem that was fixed on the trunk long ago and it somehow never made it over to the v1.0 branch. Brian ported it over earlier today; it'll be in the 1.0.2a13 that should be on the web site in a few hours.
>

That's Ok for the reference problem, that was fixed in
the 1.0.2a13 version. But I still got the hieroglyphs when running
mpirun, and I still got the same error attempting to force interface
exclusion, with this new version.

Thanks in advance for any help.

Francoise

>
>
>>-----Original Message-----
>>From: users-bounces_at_[hidden]
>>[mailto:users-bounces_at_[hidden]] On Behalf Of Francoise Roch
>>Sent: Wednesday, March 29, 2006 7:08 AM
>>To: users_at_[hidden]
>>Subject: [OMPI users] openmpi-1.0.2a12 on solaris opteron
>>
>>
>>Hello,
>>
>>I am attempting to run openmpi-1.0.2a12 on solaris opteron.
>>I compile in 64 bit mode, with Studio11 compilers
>>
>>The configure and the make run fine.
>>
>>I compile my application with :
>>mpicc -o myapp myapp.c
>>
>>1/ I have the following hieroglyphs and error message when launching
>>mpirun :
>>
>>icare> mpirun -np 4 -host icare ./myapp
>>T0<ú²þÿÿ+½T0<ú²þÿÿ4½T0<ú²þÿÿ=½T0<ú²þÿÿF½ld.so.1: myapp: fatal:
>>relocation error: file
>>/users/roch/lib/openmpi-1.0.2a12/lib/libmca_common_sm.so.0: symbol
>>nanosleep: referenced symbol not found
>>ld.so.1: all2all: fatal: relocation error: file
>>/users/roch/lib/openmpi-1.0.2a12/lib/libmca_common_sm.so.0: symbol
>>nanosleep: referenced symbol not found
>>ld.so.1: all2all: fatal: relocation error: file
>>/users/roch/lib/openmpi-1.0.2a12/lib/libmca_common_sm.so.0: symbol
>>nanosleep: referenced symbol not found
>>ld.so.1: all2all: fatal: relocation error: file
>>/users/roch/lib/openmpi-1.0.2a12/lib/libmca_common_sm.so.0: symbol
>>nanosleep: referenced symbol not found
>>
>>The problem is fixed by compiling with -lrt option :
>>mpicc -lrt -o myapp myapp.c
>>
>>2/ I attempted to force interface exclusion without success :
>>
>>n14 > mpirun --mca btl_tcp_if_exclude bge1 -np 2 -host p14,p39 myapp
>>9ÿÿÿÿÿýD $ ½T Ö¡¸ÿÿÿÿý $ ½Process 0 is alive on n14
>>Process 1 is alive on n39
>>[n39:26824] *** An error occurred in MPI_Barrier
>>[n39:26824] *** on communicator MPI_COMM_WORLD
>>[n39:26824] *** MPI_ERR_INTERN: internal error
>>[n39:26824] *** MPI_ERRORS_ARE_FATAL (goodbye)
>>
>>
>>Best Regards,
>>Francoise
>>
>>--
>>
>>_______________________________________________
>>users mailing list
>>users_at_[hidden]
>>http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>