Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Davide Bergamasco (bergamasco_at_[hidden])
Date: 2006-03-15 20:00:34


Hello Emanuel,

thank you for your note. You indirectly fixed my issue. The -prefix
option was there because at the beginning of times, when I installed
everything, I didn't properly setup my environment. The environment was
fixed at a later time, but I forgot to remove the -prefix from my
scripts. After reading your message, I got rid of it and "magically"
everything works just fine now.

Thank you very much for your help.

Davide

PS - Many thanks to Galen too.

Emanuel Ziegler wrote:
> Hi Davide!
>
> You are using the -prefix option. I guess this is due to the fact that You
> cannot set the paths appropriately. Most likely You are using rsh for
> starting remote processes.
>
> This causes some trouble since the environment offered by rsh lacks many
> things that a usual login environment offers (e.g. the path is hardcoded
> and cannot be changed).
>
> Checking with
> mpirun -np 2 -prefix /usr/local /bin/bash -c ulimit -l
> may result in reporting plenty of memory (according to Your settings) but
> this is not reliable since the new bash instance sets the limits
> differently.
> Unfortunately
> mpirun -np 2 -prefix /usr/local ulimit -l
> does not work, since mpirun expects an executable. So the only way to
> check is to run rsh directly like
> rsh remotenode ulimit -l
> (where remotenode has to be replaced by the name of the remote host). This
> may give a different result (e.g. 32 which is way too small). In my case
> this problem was solved by adding
> session required pam_limits.so
> at the end of the file "/etc/pam.d/rsh".
>
> In case of ssh check the file "/etc/pam.d/ssh" for a line similar to the
> one above and add it if it does not yet exist.
>
> Hope that helps,
> Emanuel
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>