Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Pierre Valiron (Pierre.Valiron_at_[hidden])
Date: 2006-03-13 16:05:22


Brian Barrett wrote:
>> b) whatever the code was compiled with mpif77 or mpif90, execution
>> fails:
>>
>> valiron_at_icare ~/BENCHES > mpirun -np 2 all
>> Signal:11 info.si_errno:0(Error 0) si_code:1(SEGV_MAPERR)
>> Failing at addr:40
>> *** End of error message ***
>> Signal:11 info.si_errno:0(Error 0) si_code:1(SEGV_MAPERR)
>> Failing at addr:40
>> *** End of error message ***
>>
>
> Does this code work with other MPI implementations? I'm still trying
> to track the problem down, but it looks like an invalid request is
> cropping up in a call to MPI_Wait and that is causing the
> segmentation fault. There may be another issue, but I need to do a
> bit more testing to be sure.
>
>
> Brian
>
You are right, there is a bug in the code for algo=3 and algo=4.
This bug was harmless with lam/mpi.
Now open/mpi works fine !!!
Pierre.

-- 
Soutenez le mouvement SAUVONS LA RECHERCHE :
http://recherche-en-danger.apinc.org/
       _/_/_/_/    _/       _/       Dr. Pierre VALIRON
      _/     _/   _/      _/   Laboratoire d'Astrophysique
     _/     _/   _/     _/    Observatoire de Grenoble / UJF
    _/_/_/_/    _/    _/    BP 53  F-38041 Grenoble Cedex 9 (France)
   _/          _/   _/    http://www-laog.obs.ujf-grenoble.fr/~valiron/
  _/          _/  _/     Mail: Pierre.Valiron_at_[hidden]
 _/          _/ _/      Phone: +33 4 7651 4787  Fax: +33 4 7644 8821
_/          _/_/