Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Brian Barrett (brbarret_at_[hidden])
Date: 2006-03-09 21:13:46


On Mar 3, 2006, at 10:50 AM, Troy Telford wrote:

> On Thu, 02 Mar 2006 03:55:46 -0700, Jeff Squyres <jsquyres_at_open-
> mpi.org> wrote:
>
>>> That being said, I have been unable to get OpenMPI to compile with
>>> PGI 6.1
>>> (but it does finish ./configure; it breaks during 'make').
>
>> Can you provide some details on what is going wrong?
>> We currently only have PGI 5.2 and 6.0 to test with.
>
> No. I refuse :p
>
> Attatched is a tar.bz2 with the config.log and the output of 'make'.
>
> I wouldn't doubt it if it's just a problem with the way I have PGI
> 6.1 set up; I just haven't had time to investigate it yet.

I think I have this fixed on the trunk. It looks like PGI tried to
make the 6.1 compilers support GCC inline assembly, but it doesn't
look like it's 100% correct, so for now we disabled our inline
assembly support with PGI 6.1, so it will use the non-inlined
version, just like the other versions of the PGI compilers.

Any tarball on the trunk after r9240 should have the fix. I've asked
that this gets pushed into the 1.0 branch to become part of Open MPI
1.0.2.

Brian

-- 
   Brian Barrett
   Open MPI developer
   http://www.open-mpi.org/