Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Tom Rosmond (rosmond_at_[hidden])
Date: 2006-03-09 14:51:00


Hi,

I am trying to install OPENMPI on a Linux cluster with 22 dual Opteron
nodes
and a Myrinet interconnect. I am having trouble with the build with the GM
libraries. I configured with:

./configure --prefix-/users/rosmond/ompi --with-gm=/usr/lib64
--enable-mpi2-one-sided

and the environmental variables:

setenv FC pgf90
setenv F77 pgf90
setenv CCPFLAGS /usr/include/gm ! (note this non-standard location)

The configure seemed to go OK, but the make failed. As you see at the
end of the
make output, it doesn't like the format of libgm.so. It looks to me
that it is using
a path (/usr/lib/.....) to 32 bit libraries, rather than 64 bit
(/usr/lib64/....). Is this
correct? What's the solution?

Tom Rosmond