Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Jose Pedro Garcia Mahedero (jpgmahedero_at_[hidden])
Date: 2006-03-03 09:07:52


Jeff --

I've tried waht you told me and made some tests:

cluster master machine
eth0 mpihosts_out --> for outside use (getting its own ip via dhcp)
eth1, mpihosts_cluster --> for cluster use (serves ip's to cluster nodes)

 ------- TESTS 1,2 -openmpi-1.0.2a9 ------

1.- cd openmpi-1.0.1
2.- make clean
3.- cd openmpi-1.0.2a9
4.- ./configure
5.- make all install

no parameters /usr/local/etc/openmpi-mca-params.conf
mpirun -np 2 --hostfile mpihosts_cluster ping_pong
mpirun -np 2 --hostfile mpihosts_out ping_pong

GIve the same results:

Signal:11 info.si_errno:0(Success) si_code:1(SEGV_MAPERR)
Failing at addr:0x6
*** End of error message ***
[0] func:/usr/local/lib/libopal.so.0 [0x40101cb2]
[1] func:[0xffffe440]
[2] func:/usr/local/lib/openmpi/mca_btl_tcp.so [0x404541d6]
[3] func:/usr/local/lib/openmpi/mca_btl_tcp.so(mca_btl_tcp_add_procs+0x149)
[0x404502f9]
[4] func:/usr/local/lib/openmpi/mca_bml_r2.so(mca_bml_r2_add_procs+0x155)
[0x40440e95]
[5] func:/usr/local/lib/openmpi/mca_pml_ob1.so(mca_pml_ob1_add_procs+0xa2)
[0x40429492]
[6] func:/usr/local/lib/libmpi.so.0(ompi_mpi_init+0x3c7) [0x40088127]
[7] func:/usr/local/lib/libmpi.so.0(MPI_Init+0xf1) [0x4007cac1]
[8] func:ping_pong(main+0x22) [0x804e0e6]
[9] func:/lib/tls/libc.so.6(__libc_start_main+0xf4) [0x4024d974]
[10] func:ping_pong(__gxx_personality_v0+0x3a1) [0x804e021]

 ------- TESTS 3 openmpi-1.0.2a9 -------
into /usr/local/etc/openmpi-mca-params.conf
btl_tcp_if_include = eth1

mpirun -np 2 --hostfile mpihosts_cluster ping_pong

does NOTHING, it is stalled

  ------- TESTS 4 openmpi-1.0.2a9 -------
mpirun -np 2 --hostfile mpihosts_out ping_pong
btl_tcp_if_include = eth0

OK

-------- TESTS 5 openmpi-1.0.1-------
1.- cd openmpi-1.0.2a9
2.- make clean
3.- cd openmpi-1.0.1
4.- ./configure
5.- make all install

no parameters into /usr/local/etc/openmpi-mca-params.conf
mpirun -np 2 --hostfile mpihosts_out ping_pong
IT BLOCKS

-------- TESTS 6 openmpi-1.0.1-------

mpirun -np 2 --hostfile mpihosts_out ping_pong
into /usr/local/etc/openmpi-mca-params.conf
btl_tcp_if_include = eth0

OK

-------- TESTS 7 openmpi-1.0.1-------

mpirun -np 2 --hostfile mpihosts_cluster ping_pong
into /usr/local/etc/openmpi-mca-params.conf
btl_tcp_if_include = eth1

OK

-----------------------------------

So in my opinion it still doesn't work without having to set parameters in
the config file.

I hope this helps. You all are doing a great job!