Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Adams Samuel D Contr AFRL/HEDR (Samuel.Adams.ctr_at_[hidden])
Date: 2006-03-02 11:08:23


I am trying to build OpenMPI using Lahey Fortran 95 6.2 on a Fedora Core 3
box. I run the configure script ok, but the problem occurs when run make.
It appears that it is bombing out when it is building the Fortran libraries.
It seems like to me that OpenMPI is naming its modules with .ompi_mod
instead of .mod which my compiler expects. Included below is the output
from what I was doing with building the code. Do you know how to tell the
configure script to only make .mod modules, or is there something else that
I need to do?

Output:
--------I think this is the relevant part-----------
creating libmpi_f77.la
(cd .libs && rm -f libmpi_f77.la && ln -s ../libmpi_f77.la libmpi_f77.la)
make[4]: Leaving directory `/root/openmpi-1.0.1/ompi/mpi/f77'
make[3]: Leaving directory `/root/openmpi-1.0.1/ompi/mpi/f77'
Making all in f90
make[3]: Entering directory `/root/openmpi-1.0.1/ompi/mpi/f90'
lf95 -I../../../include -I../../../include -I. -c -o mpi_kinds.ompi_module
mpi_kinds.f90
f95: fatal: "mpi_kinds.ompi_module": Invalid file suffix.
make[3]: *** [mpi_kinds.ompi_module] Error 1
make[3]: Leaving directory `/root/openmpi-1.0.1/ompi/mpi/f90'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/root/openmpi-1.0.1/ompi/mpi'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/openmpi-1.0.1/ompi'
make: *** [all-recursive] Error 1

---------------attached is the rest of the output----------------

Sam Adams
General Dynamics - Network Systems