Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2006-02-13 07:35:52


On Feb 12, 2006, at 7:28 PM, James Conway wrote:

>> - Have you absolutely entirely disabled all firewalling between the
>> two hosts?
>
> As far as I know - simply, hit the "Stop" button on Mac OSX Sharing
> pref-panel for Firewall, on the local and remote systems both (one is
> my PowerBook G4, the other my PowerMac G5).

Sounds like this should be sufficient.

>> - Do you have only one TCP interface on both machines? If you have
>> more than one, we can try telling Open MPI to ignore one of them.
>
> Interesting idea. The remote machine has two ethernet ports
> (PowerMac) and the local machine has ethernet and airport. Only one
> port should be enabled on each, but the PowerBook airport is what I
> use at home so maybe it didn't get properly disabled when I switched
> to my work settings. Since the call to MPI-send seems to hand on the
> local host, it may be an attempt to use the airport (wireless)
> connection. How to I tell Open MPI to ignore a particular interface?

Check out http://www.open-mpi.org/faq/?category=tcp#tcp-selection --
it talks about the MCA parameters you can use to specify different
networks. For example, on my powerbook, en0 appears to be my wired
connection.

Let us know what happens.

-- 
{+} Jeff Squyres
{+} The Open MPI Project
{+} http://www.open-mpi.org/