Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: James Conway (jxc100_at_[hidden])
Date: 2006-02-12 19:28:41


Jeff,

Thanks for your responses.

On Feb 12, 2006, at 5:23 PM, Jeff Squyres wrote:

> On Feb 10, 2006, at 12:18 PM, James Conway wrote:
>
>>> Open MPI uses random port numbers for all it's communication.
>>> (etc)
>>
>> Thanks for the explanation. I will live with the open Firewall, and
>> look at the ipfw docs for writing a script.
>
> That may be somewhat difficult. We previously looked into making
> LAM/ MPI work behind firewalls and ran into some unexpected issues
> -- the short version was that, at least for the way LAM was setup,
> even if you could restrict the port numbers that LAM would choose
> for its TCP communications, you had to have a virtual host out in
> front of the firewall that would relay the traffic to the
> appropriate internal host. Specifically, you had to have an IP
> address out in front of the firewall for each host so that it would
> route to the appropriate back-end instance of the MPI application
> on the appropriate host.
> ...

Unfortunately, while not completely illiterate, I am not following
this as much as I would like, but thanks for the explanation. It
seems (and correct me if I am wrong) that the bottom line is to use
some private network as one would in a dedicated cluster.

Re: my problem with the "MPI Tutorial: The cannonical ring program"
from <http://www.lam-mpi.org/tutorials/>.

> Well that is definitely odd. The fact that the first send finishes
> and the second does not is quite fishy. A few questions:

Yes, good, I am glad I had thought it out that far (ie, I don't seem
to have embarrassed myself utterly - yet).

> - Have you absolutely entirely disabled all firewalling between the
> two hosts?

As far as I know - simply, hit the "Stop" button on Mac OSX Sharing
pref-panel for Firewall, on the local and remote systems both (one is
my PowerBook G4, the other my PowerMac G5). It seems very suggestive
that one round of the ring works OK. (For both machines I set one
process for MPI with "--np 1", even though the PMac has 4 cores -
easier to troubleshoot).

> - Do you have only one TCP interface on both machines? If you have
> more than one, we can try telling Open MPI to ignore one of them.

Interesting idea. The remote machine has two ethernet ports
(PowerMac) and the local machine has ethernet and airport. Only one
port should be enabled on each, but the PowerBook airport is what I
use at home so maybe it didn't get properly disabled when I switched
to my work settings. Since the call to MPI-send seems to hand on the
local host, it may be an attempt to use the airport (wireless)
connection. How to I tell Open MPI to ignore a particular interface?
It seems worth a try.

Thanks again for your help.

James Conway
----------------------------------------------------------------------
James Conway, PhD.,
Department of Structural Biology
University of Pittsburgh School of Medicine
Biomedical Science Tower 3, Room 2047
3501 5th Ave
Pittsburgh, PA 15260
U.S.A.
Phone: +1-412-383-9847
Fax: +1-412-648-8998
Email: jxc100_at_[hidden]
Web: <http://www.pitt.edu/~jxc100/> (under construction)
----------------------------------------------------------------------