Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Glen Kaukola (glen_at_[hidden])
Date: 2006-02-10 18:58:08


Jeff Squyres wrote:
> On Feb 6, 2006, at 8:32 PM, Glen Kaukola wrote:
>
>> Anyway, here are the times on a few runs I did with Open MPI
>> 1.1a1r887.
>> Basically what I'm seeing, my jobs run ok when they're local to one
>> machine, but as soon as they're split up between multiple machines
>> performance can vary:
>>
>> 4 cpu jobs:
>> 2:16:27
>> 2:01:35
>> 1:24:20
>> 1:03:55
>> 1:22:43
>> 1:31:53
>
> Wow -- am I reading this correct in that you are seeing a delta of
> over 1 minute in runs of the same application with the same data?
> That should absolutely not be happening.
>
> If you haven't already (I'm joining this thread late), can you send
> us your input deck so that we can try to reproduce this?

That's in hours actually. So a delta of over one hour. And yes, it's
the same exact setup, same day, same input data and everything for each job.

You're wanting to run the cctm model though? It would take a little
doing, but I could whip up a tar file with all the necessary fixings,
source, scripts, and input data. Bear in mind that it would probably be
anywhere from 2 to 5 gigs in size just to do a one day simulation. I
think the EPA might put out some sample data though that's a bit more
manageable, so I could maybe set that up instead, but we'd still be
talking around 1 gigabyte worth of data I think. Oh, and you pretty
much need the Portland Group's Fortran 95 compiler for things to work.

Glen