Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Berend van Wachem (berend_at_[hidden])
Date: 2006-02-10 07:52:18


Hi,

I have always used MPICH for my MPI projects, but changed to open-mpi
for its better integration with eclipse.

First of all, I got an error when using gcc 4.x when compiling the code,
but I think this was discussed earlier on the mailinglist.

I downgraded gcc and have succesfully compiled open-mpi. However, when I
run my project with 6 processors, I get the error:

*** glibc detected *** malloc(): memory corruption: 0x0000000000f09190 ***

I have no idea where it comes from or how to debug this. Can anyone
provide me with information or hints?

I am using openmpi-1.0.2a1, gcc (GCC) 3.4.4 om amd64 linux.

Thanks,

Berend.