Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Andrew Friedley (afriedle_at_[hidden])
Date: 2006-02-07 08:57:16


Hello,

Can you give us more details on the problem? The exact error message,
as well as the contents of your hostfile will help. You should check
out our FAQ as well, as it likely will help you solve your problem:

http://www.open-mpi.org/faq/

Particularly the sections 'Running MPI jobs' and 'Running jobs under
rsh/ssh'.

Make is not a very good program to test with - try something simpler
instead:

mpirun -np 2 --hostfile /mnt/wolf/lamhosts hostname

The hostname of both nodes should be printed.

Another note - are you just trying to run a parallel make? If so,
distcc and ccache are a better solution.

Andrew

Andreas Fladischer wrote:
> hi_at_all!
>
> i have a question to the parallel mpirun!i have a small cluster (for
> testing purpose one headnode and one node) which running fedora core 3!
> i installed openmpi on both nodes and created a user with the same uid
> on both nodes; now i try to build the glibc tools from the headnode but
> there couldn't be a connection to the second node;
>
> time mpirun -np 2 --hostfile /mnt/wolf/lamhosts make
>
> i'm a newbee on the mpi tools and so i have no plan what i do wrong; in
> additional i couldn't find a good documentation exluding the faq's on
> the homepage; are there some howto's available?
>
> thanks in advance?
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users