Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Warner Yuen (wyuen_at_[hidden])
Date: 2006-02-03 21:30:52


Hello Everyone:

Thanks to Brian Barrett's help, I was able to get Open MPI working
with Xgrid using two dual 2.5 GHz PowerMacs. I can submit HP Linpack
jobs fine and get all four CPUs cranking, but I'm having problems
with the applications that I really want to run, MrBayes and GROMACS
(two very different programs...but both are MPI enabled)

I can submit the MPI job to a single Xgrid agent and they run just
fine, but if I try adding the second agent (the second PowerMac) the
jobs abort after a few seconds. Running them without Xgrid but just
OpenMPI, the applications run fine. Below is the output...not very
informative, but if anyone has any ideas I'd appreciate it.

For GROMACS I end up with the following:

-------------------------------------------------------
Program mdrun_mpi, VERSION 3.3
Source code file: futil.c, line: 308

File input/output error:
md0.log
-------------------------------------------------------

For MrBayes I get the following:

Overwriting file "testdata.nex.run1.p"
Could not open file "testdata.nex.run1.p"
Memory allocation error on at least one processor
Error in command "Mcmc"
There was an error on at least one processor
Error in command "Execute"
Will exit with signal 1 (error)

Warner Yuen
Research Computing Consultant
Apple Computer
email: wyuen_at_[hidden]
Tel: 408.718.2859
Fax: 408.715.0133