Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Kraig Winters (kraig_at_[hidden])
Date: 2006-01-19 11:57:25


Interesting. Since I submitted the report below, I tried installing
v1.01 on my powerbook which also had 10.4.3, the same compiler
versions etc. On the powerbook, ./configure --> make --> make install
worked brilliantly. I began exploring what could be different on the
2 machines. I checked the versions of everything that seemed
relevant (autoconf, env variables, sh etc) and everything matched.
The machines are so similar I was actually able to configure on the
powerbook and compile/install on the dual G5.

Yesterday afternoon, I did a software update to 10.4.4 on the
dual G5 machine (the one on which I was having trouble).
This morning, to regenerate the config.status file for you, I ran the
same configure command:
         ./configure --prefix=/usr/local/openmpi
and everything worked fine!! make and sudo make install also
worked perfectly.

Google searching on

sed: unescaped newline inside substitute pattern

shows that this error crops up fairly often, in different
software packages, usually (always?) associated with
conftest, often w/ OS X but not always. Unfortunately
are no solutions posted, at least that I could find.

In the end, I suspect it was the restart rather than
the OS upgrade that fixed the problem, though I can't
imagine what kind of problem got corrected. I wasn't
having any other problems though I was running all
sorts of different applications, including ./configure
on, for example, petsc.

I'm confused but happy that things are working nicely.
Thanks for having a look.
Kraig

On Jan 18, 2006, at 7:25 PM, Jeff Squyres wrote:

> Sorry it's taken a few days to look at this -- I'm unable to
> replicate your problem on a 10.4.3 machine, but I'm only using the
> gnu compilers (the IBM compilers are not officially supported on
> Tiger -- I wouldn't expect that to be the problem here, but anything
> is possible).
>
> Can you send your config.status file? (please compress)
>
>
>
> On Jan 13, 2006, at 8:48 PM, Kraig Winters wrote:
>
>> Hi.
>> I'm having trouble configuring v1.0.1 on a system
>> running OS X 10.4.3, using gcc/xlf. The configure script
>> is happy until it's in it's final stages and begins to
>> create the makefiles. Each time it attempts to create
>> a new makefile, the following error is produced:
>>
>> config.status: creating test/mca/ns/Makefile
>> sed: 23: ./confstatBmI51v/subs-4.sed: unescaped newline inside
>> substitute pattern
>>
>> The configure then runs to completion but of course each and every
>> makefile is empty. I've enclosed the log and screen output.
>>
>> Thanks,
>> Kraig
>> <config_output.tar.bz2>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> --
> {+} Jeff Squyres
> {+} The Open MPI Project
> {+} http://www.open-mpi.org/
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users