Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: John Ouellette (ouellet_at_[hidden])
Date: 2005-11-29 09:52:19


Hi Tim,

Hmmmm, nope. I recompiled OpenMPI to produce the static libs, and even
recompiled my app statically, and received the same error messages.

If orted isn't starting on the compute nodes, is there any way I can debug
this to find out where it is failing?

Actually, I just tried your suggestion of running ldd on one of the compute
nodes (should've tried this before recompiling, I guess...). I get a strange
error, which probably indicates a problem with bproc:

ldd /usr/local/intel-libs/9.0/bin/orted
/proc/self/fd/3: line 125: cat: command not found

I know I've run ldd on a node before without problems before.... I don't know
if this is related to my OpenMPI problems, but I'm going to have to look into
it.

John

>Hello John,
>
>You need to specify both --enable-static and --disable-shared to do a static
>build (not sure why, perhaps someone else can fill us in on that)...
>
>The logs indicate the launch is failing trying to start orted on the backend
>node... probably due to shared library dependencies.
>
>You might try doing a bpsh <node> ldd orted
>
>And check that the libraries resolve / and or rebuild with the indicated
>configure option.

>Regards,
>Tim
>

-- 
+++++++++++++++++++++++++++++++++++
John Ouellette
Department of Astrophysics
American Museum of Natural History
Ph: 212-313-7919 Fax: 212-769-5007