Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2005-11-15 11:43:58


Daryl --

I don't think that anyone directly replied to you, but I saw some
commits fixing this yesterday (actually, they were already on the
trunk; we forgot to bring them over to the v1.0 branch). Could you
give this morning's nightly snapshot tarball a whirl?

On Nov 14, 2005, at 10:30 AM, Daryl W. Grunau wrote:

> Hi, I'm trying to compile rc6 on my BProc cluster and failed to build
> as
> follows:
>
> make[4]: Entering directory
> `/usr/src/redhat/BUILD/openmpi-1.0rc6/orte/mca/pls/bproc'
> depbase=`echo pls_bproc.lo | sed 's|[^/]*$|.deps/&|;s|\.lo$||'`; \
> if /bin/sh ../../../../libtool --tag=CC --mode=compile gcc
> -DHAVE_CONFIG_H -I. -I. -I../../../../include -I../../../../include
> -I/usr/src/redhat/BUILD/openmpi-1.0rc6/src/include
> -DORTE_BINDIR="\"/opt/OpenMPI/openmpi-1.0rc6/ib/bin\""
> -I../../../../include -I../../../.. -I../../../..
> -I../../../../include -I../../../../opal -I../../../../orte
> -I../../../../ompi -DNDEBUG -O2 -g -pipe -m64 -fno-strict-aliasing
> -pthread -MT pls_bproc.lo -MD -MP -MF "$depbase.Tpo" -c -o
> pls_bproc.lo pls_bproc.c; \
> then mv -f "$depbase.Tpo" "$depbase.Plo"; else rm -f "$depbase.Tpo";
> exit 1; fi
> gcc -DHAVE_CONFIG_H -I. -I. -I../../../../include
> -I../../../../include
> -I/usr/src/redhat/BUILD/openmpi-1.0rc6/src/include
> -DORTE_BINDIR=\"/opt/OpenMPI/openmpi-1.0rc6/ib/bin\"
> -I../../../../include -I../../../.. -I../../../..
> -I../../../../include -I../../../../opal -I../../../../orte
> -I../../../../ompi -DNDEBUG -O2 -g -pipe -m64 -fno-strict-aliasing
> -pthread -MT pls_bproc.lo -MD -MP -MF .deps/pls_bproc.Tpo -c
> pls_bproc.c -o pls_bproc.o
> pls_bproc.c: In function `orte_pls_bproc_node_array':
> pls_bproc.c:122: error: structure has no member named `node_name'
> pls_bproc.c:123: error: structure has no member named `node_name'
> pls_bproc.c:140: error: structure has no member named `node_name'
> make[4]: *** [pls_bproc.lo] Error 1
> make[4]: Leaving directory
> `/usr/src/redhat/BUILD/openmpi-1.0rc6/orte/mca/pls/bproc'
> make[3]: *** [all-recursive] Error 1
> make[3]: Leaving directory
> `/usr/src/redhat/BUILD/openmpi-1.0rc6/orte/mca/pls'
> make[2]: *** [all-recursive] Error 1
> make[2]: Leaving directory
> `/usr/src/redhat/BUILD/openmpi-1.0rc6/orte/mca'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/usr/src/redhat/BUILD/openmpi-1.0rc6/orte'
> make: *** [all-recursive] Error 1
>
>
> Here's the full configure line (from config.log):
>
> $ ./configure --build=x86_64-redhat-linux-gnu
> --host=x86_64-redhat-linux-gnu --target=x86_64-redhat-linux-gnu
> --program-prefix= --prefix=/opt/OpenMPI/openmpi-1.0rc6/ib
> --exec-prefix=/opt/OpenMPI/openmpi-1.0rc6/ib
> --bindir=/opt/OpenMPI/openmpi-1.0rc6/ib/bin
> --sbindir=/opt/OpenMPI/openmpi-1.0rc6/ib/sbin --sysconfdir=/etc
> --datadir=/opt/OpenMPI/openmpi-1.0rc6/ib/share
> --includedir=/opt/OpenMPI/openmpi-1.0rc6/ib/include
> --libdir=/opt/OpenMPI/openmpi-1.0rc6/ib/lib64
> --libexecdir=/opt/OpenMPI/openmpi-1.0rc6/ib/libexec
> --localstatedir=/var
> --sharedstatedir=/opt/OpenMPI/openmpi-1.0rc6/ib/com
> --mandir=/usr/share/man --infodir=/usr/share/info
> --prefix=/opt/OpenMPI/openmpi-1.0rc6/ib
> --sysconfdir=/opt/OpenMPI/openmpi-1.0rc6/ib/etc --disable-shared
> --enable-static --with-bproc
> --with-mvapi=/opt/IB/ibgd-1.8.0/driver/infinihost
>
>
> Any advice appreciated!
>
> Daryl
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>

-- 
{+} Jeff Squyres
{+} The Open MPI Project
{+} http://www.open-mpi.org/