Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2005-08-23 19:49:58


On Aug 23, 2005, at 2:40 PM, Galen M. Shipman wrote:

>>> I'm a little surprised that tcp was used -- OMPI should "prefer" the
>>> low latency interconnects (such as mvapi) to tcp and automatically
>>> use them.
>
> This is a small issue and should be fixed in the next day or two. In
> the meantime to run using mvapi only use:
>
> mpirun -np 2 -mca btl-base-include self,mvapi (etc...)

Slight correction -- btl_base_include, not btl-base-include.

But Galen is right -- I forgot that, effectively, a switch hadn't been
thrown in the code base to enable mvapi. With the version you
downloaded, you also need to add the "-mca pml ob1" switch to the
command line as well.

The ob1 pml component was made the default today at the subversion
trunk HEAD, so tonight's tarball should "just work" with mvapi (without
the need for either -mca switch -- btl_base_include or pml).

Sorry for not thinking of that earlier... :-\

As for "--verbose", that's on the list. There's actually a bunch of
individual verbose settings (as MCA parameters) that you can enable
(see "ompi_info --param all all --parsable | grep verbose"), but it's a
goal to have a single, top-level --verbose switch that is effectively
an alias for most/all of them.

-- 
{+} Jeff Squyres
{+} The Open MPI Project
{+} http://www.open-mpi.org/