Open MPI logo

Network Locality users Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Network Locality users mailing list

Subject: Re: [netloc-users] Trying Netloc on a small IB cluster
From: Brice Goglin (Brice.Goglin_at_[hidden])
Date: 2013-12-06 03:44:13


Also
How did you gather the ibnetdiscover/ibroute files?
Did you run the netloc-gather-ib script? Or did you run
ibnetdiscover/ibroute manually?
Can you show the contents (filenames only) of the output files?
Brice

Le 05/12/2013 18:30, Josh Hursey a écrit :
> Raghu,
>
> The probably is likely that the subnet has not been specified. The
> netloc_reader_ib is not terribly user friendly at the moment. We have
> some supporting tools that help make it easier to use. I highlighted
> the steps for another user in the mail linked below:
> http://www.open-mpi.org/community/lists/netloc-devel/2013/11/0005.php
>
> Notice that it does not call netloc_reader_ib explicitly, it is
> wrapped up as part of the netloc-ib-extract-dats script.
>
>
> You will also need to install Jansson (if you have not already) as
> that is how netloc is currently representing the data (it may change
> in the future, but this works well for now). It can be downloaded from:
> http://www.digip.org/jansson/
>
>
> I am currently working on some FAQs to hopefully help answer these
> types of questions in the future. In the mean time feel free to email
> and we can go from there.
>
> Thanks,
> Josh
>
>
>
> On Thu, Dec 5, 2013 at 3:18 PM, Jeff Squyres (jsquyres)
> <jsquyres_at_[hidden] <mailto:jsquyres_at_[hidden]>> wrote:
>
> Adding netloc-users into the CC; this is the type of feedback we
> need, and the type of stuff we want to make google-able for others.
>
> FYI: Brice did most of the IB work, and he's at a conference this
> week. So the reply for this may be a little delayed...
>
>
> On Dec 5, 2013, at 2:56 PM, Raghu <rajachan_at_[hidden]
> <mailto:rajachan_at_[hidden]>> wrote:
>
> > Hi Josh, Jeff,
> >
> > I am trying out netloc (the master branch) on a small IB cluster
> > (which I have sudo access to). I got stuff built fine, but when
> I try
> > to generate the .ndat files, I am getting this:
> >
> > Output Directory : /home/rajachan/netloc/install/bin/output/
> > Subnet : unknown
> > ibnetdiscover File : /home/rajachan/netloc/install/bin/ibnetdata
> > ibroutes Directory : None Specified
> > Status: Querying the ibnetdiscover data for subnet unknown...
> > Error: Invalid network type provided
> > Error: Failed to create a new data file
> >
> > Here's how I am running the reader : ./netloc_reader_ib -o
> > /home/rajachan/netloc/install/bin/output/ -f
> > /home/rajachan/netloc/install/bin/ibnetdata
> >
> > Do you guys see any glaring config mistake from my end?
> >
> > Raghu
>
>
> --
> Jeff Squyres
> jsquyres_at_[hidden] <mailto:jsquyres_at_[hidden]>
> For corporate legal information go to:
> http://www.cisco.com/web/about/doing_business/legal/cri/
>
> _______________________________________________
> netloc-users mailing list
> netloc-users_at_[hidden] <mailto:netloc-users_at_[hidden]>
> http://www.open-mpi.org/mailman/listinfo.cgi/netloc-users
>
>
>
>
> --
> Joshua Hursey
> Assistant Professor of Computer Science
> University of Wisconsin-La Crosse
> http://cs.uwlax.edu/~jjhursey <http://cs.uwlax.edu/%7Ejjhursey>
>
>
> _______________________________________________
> netloc-users mailing list
> netloc-users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/netloc-users