To followup on this, I think I got it right by just using: 
 
perl Makefile.PL LIB=/usr/projects/hpctools/jennyp/mtt PREFIX=/usr/projects/hpctools/jennyp/mtt
setenv PERLIB /usr/projects/hpctools/jennyp/mtt
 
I then copied ompi-core-template.ini  (made no changes to it).  But:
 
ffe2:/<2>hpctools/jennyp/mtt [205] > ./client -d --force -f ompi-core-template.ini
Unable to find MTT support libraries at ./client line 78.
BEGIN failed--compilation aborted at ./client line 81.
ffe2:/<2>hpctools/jennyp/mtt [206] > ./client -help
Unable to find MTT support libraries at ./client line 78.
BEGIN failed--compilation aborted at ./client line 81.
 
 
I can't help but feel that I'm doing something wrong.
Help?  Do I need to read another document?
 
------------original issue-----------------

I'm following the instructions on the MTT setup page.
 
Would someone clarify the <your dir> parameters below.
PREFIX is logically (to me) "where I am putting MTT" , yes?
 
But LIB is always confusing. Is this some MPI lib directory,
a perl library or the same as <your dir> above - where I am putting MTT.
 
And if so, how do I find where those happen
to reside?
 
Pointing PERLLIB means setting the env var, right?
 
New to this, thanks.,
Jenny
 
-----------------------------------------------------------------------
Jennis (Jenny) Pruett
Los Alamos National Laboratory
505-667-1955