Hi,

I’m trying to run MTT version 2.1.

In the test build phase, some of the builds fails. For example:

The build output of the ibm test looks like this:

 

Evaluating: ./configure CC=mpicc CXX=mpic++ F77=mpif77

   make

Running command: /tmp/IhYOhJexxR

OUT:configure: loading site script /usr/local/share/config.site

OUT:configure: loading site script /usr/local/etc/config.site

OUT:Configuring Open MPI/IBM test suite

OUT:checking for a BSD-compatible install... OUT:(cached) OUT:/usr/bin/install -c

OUT:checking whether build environment is sane... OUT:yes

OUT:checking for gawk... OUT:(cached) OUT:gawk

OUT:checking whether make sets $(MAKE)... OUT:(cached) OUT:yes

OUT:checking build system type... OUT:(cached) OUT:x86_64-unknown-linux-gnu

OUT:checking host system type... OUT:x86_64-unknown-linux-gnu

OUT:checking for gcc... OUT:(cached) OUT:gcc

OUT:checking for C compiler default output file name... OUT:a.out

OUT:checking whether the C compiler works... OUT:yes

OUT:checking whether we are cross compiling... OUT:no

OUT:checking for suffix of executables... OUT:

OUT:checking for suffix of object files... OUT:(cached) OUT:o

OUT:checking whether we are using the GNU C compiler... OUT:(cached) OUT:yes

OUT:checking whether gcc accepts -g... OUT:(cached) OUT:yes

OUT:checking for gcc option to accept ANSI C... OUT:(cached) OUT:none needed

OUT:checking for style of include used by make... OUT:GNU

OUT:checking dependency style of gcc... OUT:(cached) OUT:gcc3

OUT:checking whether we are using the GNU C++ compiler... OUT:(cached) OUT:yes

OUT:checking whether mpic++ accepts -g... OUT:(cached) OUT:yes

OUT:checking dependency style of mpic++... OUT:(cached) OUT:gcc3

OUT:checking for mpif77... OUT:yes

OUT:checking whether we are using the GNU Fortran 77 compiler... OUT:yes

OUT:checking whether mpif77 accepts -g... OUT:yes

OUT:checking for ranlib... OUT:(cached) OUT:ranlib

OUT:checking for mpi.h... OUT:no

OUT:configure: error: cannot continue -- cannot find <mpi.h>

OUT:make: *** OUT:No targets specified and no makefile foundOUT:.  Stop.

Command complete, exit status: 2

 

As you can see, the configure script cant find the mpi.h file.

I have this problem in other builds as well.

 

Attached my ini file.

 

Can someone help?

 

Thanks.

Sharon.