Open MPI logo

MTT Devel Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all MTT Users mailing list

Subject: Re: [MTT users] Is the stock MPI that comes with OSX leopard broken with xgrid?
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2008-12-17 09:00:53


Greetings John. I think you want to direct your mail to the Open MPI
User's mailing list -- this list is for the testing framework known as
the MPI Testing Tool (MTT). It's a sub-project of the greater Open
MPI project, but the audience over here isn't well-equipped to answer
specific questions about the Open MPI software package.

     http://www.open-mpi.org/community/lists/ompi.php

On Dec 17, 2008, at 5:35 AM, John Fink wrote:

> Hello OpenMPI folks,
>
> I've got a large pool of Macs running Leopard that are all on an
> xgrid. However, I can't seem to use the mpirun that comes with
> Leopard with the xgrid. I've got my grid and password environment
> variables set up okay on my controller, all the xgrid command line
> commands work (displaying grid IDs, things like that) but mpirun
> only wants to run things on the local host.
>
> I'm extremely new to OpenMPI and only slightly less new to Macs so
> there's probably something very obvious that I'm missing, but I'm
> trying what's detailed on this page: http://www.macresearch.org/runing_mpi_job_through_xgrid
> (the /bin/hostname example). Here's my output:
>
> as-0003-l:~ locadmin$ mpirun -n 8 /bin/hostname
> as-0003-l.lib.mcmaster.ca
> as-0003-l.lib.mcmaster.ca
> as-0003-l.lib.mcmaster.ca
> as-0003-l.lib.mcmaster.ca
> as-0003-l.lib.mcmaster.ca
> as-0003-l.lib.mcmaster.ca
> as-0003-l.lib.mcmaster.ca
> as-0003-l.lib.mcmaster.ca
>
>
>
> Issuing the same command with -nolocal yields the following:
>
> as-0003-l:~ locadmin$ mpirun --nolocal -n 8 /bin/hostname
> --------------------------------------------------------------------------
> There are no available nodes allocated to this job. This could be
> because
> no nodes were found or all the available nodes were already used.
>
> Note that since the -nolocal option was given no processes can be
> launched on the local node.
> --------------------------------------------------------------------------
> [as-0003-l.lib.mcmaster.ca:82776] [0,0,0] ORTE_ERROR_LOG:
> Temporarily out of resource in file /SourceCache/openmpi/openmpi-5/
> openmpi/orte/mca/rmaps/base/rmaps_base_support_fns.c at line 168
> [as-0003-l.lib.mcmaster.ca:82776] [0,0,0] ORTE_ERROR_LOG:
> Temporarily out of resource in file /SourceCache/openmpi/openmpi-5/
> openmpi/orte/mca/rmaps/round_robin/rmaps_rr.c at line 402
> [as-0003-l.lib.mcmaster.ca:82776] [0,0,0] ORTE_ERROR_LOG:
> Temporarily out of resource in file /SourceCache/openmpi/openmpi-5/
> openmpi/orte/mca/rmaps/base/rmaps_base_map_job.c at line 210
> [as-0003-l.lib.mcmaster.ca:82776] [0,0,0] ORTE_ERROR_LOG:
> Temporarily out of resource in file /SourceCache/openmpi/openmpi-5/
> openmpi/orte/mca/rmgr/urm/rmgr_urm.c at line 372
> [as-0003-l.lib.mcmaster.ca:82776] mpirun: spawn failed with errno=-3
>
>
> Thanks very much for any help you can provide!
>
> jf
>
> --
> http://libgrunt.blogspot.com -- library culture and technology.
> _______________________________________________
> mtt-users mailing list
> mtt-users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/mtt-users

-- 
Jeff Squyres
Cisco Systems