Open MPI logo

MTT Devel Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all MTT Users mailing list

Subject: Re: [MTT users] MTT fail to require MTT::Test::Specify::Simple
From: Wen Hao Wang (wangwhao_at_[hidden])
Date: 2008-05-23 04:22:45


Hello Jeff:

Thanks for your advice. With the password Brad sent, I found and downloaded
ibm directory of repository ompi-tests. But it seems the directory does not
contain enough files.

[root_at_xblade08 ~]# ls /LTC/MPI/ompi_lamtests/
acinclude.m4 collective config datatype environment info
LICENSE onesided README topology
autogen.sh communicator configure.ac dynamic group io
Makefile.am pt2pt reporting
[root_at_xblade08 ~]# ls /LTC/MPI/lamtests-7.1.4
acinclude.m4 check.out config.out configure.in Entering in
laminfo.out Makefile.in others topo
aclocal.m4 comm config.status directory env info
LICENSE make.out pt2pt VERSION
ccl config configure dtyp errors io
Makefile Making README
check config.log configure.bak dynamic group lam
Makefile.am onesided reporting

ompi_lamtests was got from openmpi subversion, while lamtests-7.1.4 from
lam-mpi.org. You can catch ompi_lamtests have less files than lamtests. At
least no configure file is available to configure and make. Any advice?

Moveover, any update for my MTT execution result? Thanks again.

Wen Hao Wang

                                                                           
             Jeff Squyres
             <jsquyres_at_cisco.c
             om> To
             Sent by: General user list for the MPI
             mtt-users-bounces Testing Tool
             @open-mpi.org <mtt-users_at_[hidden]>
                                                                        cc
                                                                           
             2008-05-20 20:11 Subject
                                       Re: [MTT users] MTT fail to require
                                       MTT::Test::Specify::Simple
             Please respond to
             General user list
                for the MPI
               Testing Tool
             <mtt-users_at_open-m
                  pi.org>
                                                                           
                                                                           


Right -- didn't you coordinate with Brad to get these for IBM...?

If you are running the official Open MPI nightly regression testing,
you can have access to this repository.

On May 20, 2008, at 8:13 AM, Wen Hao Wang wrote:

> But ompi-tests or ompitests also need user/password.
>
> [root_at_valiant wwh]# svn list http://svn.open-mpi.org/svn/ompitests
> Authentication realm: <http://svn.open-mpi.org:80> Open MPI
> Subversion repositories access
> Password for 'root':
> [root_at_valiant wwh]# svn list http://svn.open-mpi.org/svn/ompi-tests
> Authentication realm: <http://svn.open-mpi.org:80> Open MPI
> Subversion repositories access
> Password for 'root':
> Wen Hao Wang
>
> <graycol.gif>Jeff Squyres <jsquyres_at_[hidden]>
>
>
> Jeff Squyres <jsquyres_at_[hidden]>
> Sent by: mtt-users-bounces_at_[hidden]
> 2008-05-20 19:32
> Please respond to
> General user list for the MPI Testing Tool <mtt-users_at_[hidden]>
> <ecblank.gif>
> To
> <ecblank.gif>
> General user list for the MPI Testing Tool <mtt-users_at_[hidden]>
> <ecblank.gif>
> cc
> <ecblank.gif>
> <ecblank.gif>
> Subject
> <ecblank.gif>
> Re: [MTT users] MTT fail to require MTT::Test::Specify::Simple
> <ecblank.gif>
> <ecblank.gif>
>
> On May 20, 2008, at 1:12 AM, Wen Hao Wang wrote:
>
> > I have rerun MTT with the arguments "--verbose --force -f samples/
> > ompi-core-template.ini --no-section intel --no-section 1.1". Now I
> > can see my test results in the MTT database. The platform name is
> > ibm_beijing_rhel5.2. One "Test build" case and tens of "Test run"
> > cases are marked Fail. If you have time to check them, that would be
> > greatly appreciated.
> >
>
> Good.
>
> > For lamtests you mentioned in lam mail list, I tried to check out
> > ompi and ibm respositories. ompi can be accessed but not has
> > lamtests. ibm can not be accessed without password.
> >
>
> It's not the ibm repository -- it's the ibm directory in the ompi-
> tests repository. Sorry if that was not clear.
>
> --
> Jeff Squyres
> Cisco Systems
>
> _______________________________________________
> mtt-users mailing list
> mtt-users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/mtt-users
>
> _______________________________________________
> mtt-users mailing list
> mtt-users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/mtt-users

--
Jeff Squyres
Cisco Systems
_______________________________________________
mtt-users mailing list
mtt-users_at_[hidden]
http://www.open-mpi.org/mailman/listinfo.cgi/mtt-users




graycol.gif
pic16211.gif
ecblank.gif