Open MPI logo

MTT Devel Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all MTT Users mailing list

Subject: Re: [MTT users] MTT fail to require MTT::Test::Specify::Simple
From: Wen Hao Wang (wangwhao_at_[hidden])
Date: 2008-05-15 01:56:14


Hello Jeff and Ethan:

Sorry for my delay. I deleted that line "specify_module = Simple" in ini
file, and the require failure diappeared. Thanks for your support.

Here is my MTT arguments this time:
      client/mtt -d --force -f samples/ompi-core-template.ini --trial
--no-section intel --no-section 1.1
The MTT result contains totally 22 failure. Not sure which of them are
already known issues. I suppose the failed cases are one open MPI issue,
instead of MTT issue. If that's the case, please correct me. I do not know
which bug in https://svn.open-mpi.org/trac/ompi/report/6 matches my mtt
failure in running "mpirun -np 2 --mca btl tcp,self --prefix /LTC/MTT/..."
listed below.

Is there any method to probe this failures for me? Or is there anyone to
check all my MTT failed cases? I need one method to get which failed cases
have been known and tracked.

Thanks again.

Wen Hao Wang (ÍõÎÄê»)

Software Engineer
IBM China Software Development Laboratory
Email: wangwhao_at_[hidden]
Tel: 86-10-82451055
Fax: 86-10-82782244 ext. 2312
Address: 5/F, Deshi Building, No.9 East Road Shangdi, Haidian District,
Beijing, 100085, P.R.China



                                                                           
             Jeff Squyres
             <jsquyres_at_cisco.c
             om> To
             Sent by: General user list for the MPI
             mtt-users-bounces Testing Tool
             @open-mpi.org <mtt-users_at_[hidden]>
                                                                        cc
                                       Brad Benton
             2008-05-13 20:26 <brad.benton_at_[hidden]>
                                                                   Subject
                                       Re: [MTT users] MTT fail to require
             Please respond to MTT::Test::Specify::Simple
             General user list
                for the MPI
               Testing Tool
             <mtt-users_at_open-m
                  pi.org>
                                                                           
                                                                           




On May 13, 2008, at 2:58 AM, Wen Hao Wang wrote:

> I run client/mtt with debug model, and found mtt script exited in
> following code section of lib/MTT/Module.pm.
>
> 32 my $str = "require $module";
> 33 Debug("Evaluating: $str\n");
> 34 my $check = eval $str;
>
> When require error occured, $str was set to
> "MTT::Test::Specify::Simple
> Simple".
>

Note that this *usually* indicates an error in the INI file. Perhaps
we should have better error checking/reporting for this case...

Can you send your ini file?

> This is not a valid Perl module, so mtt failed. I had no time to
> probe why/where such value was got. I just modified Module.pm to
> work around the issue.
>
> [root_at_host MTT]# !diff
> diff primary/Module.pm ./lib/MTT/Module.pm
> 31a32,38
> > if ($module =~ m/Simple/)
> > {
> > if (length($module) > 26)
> > {
> > ($module) = $module =~ m/(.*::Simple)/;
> > }
> > }
>

This should not be necessary; we all run MTT with the Specify::Simple
module every night.

> With this workaround, $str was changed back to
> "MTT::Test::Specify::Simple", and mtt script could continue. Ater
> all the tests finished, I found some MTT cases failed. For those
> failed cases, who will probe it? Or how can I probe them? Here list
> one section that returned error.
>
> | command | mpirun -np 2 --mca btl tcp,self --prefix /LTC/MTT/
> installs/Urs4/install |
> | | t_win |
> | duration | 0 seconds |
> | exit_value | 1 |
> | result_message | Failed; exit status: 1 |
> | result_stdout | WIN_BASIC: passed |
> | | WIN_OVERLAP: passed |
> | | WIN_OVERLAP2: passed |
> | | WIN_OVERLAP3: passed |
> | | LOCK_EPOCH: passed |
> | | FENCE_EPOCH: failed |
> | | MISC: passed |
> | | POST_EPOCH: passed |
> | | WIN_BASIC: passed |
> | | WIN_OVERLAP: passed |
> | | WIN_OVERLAP2: passed |
> | | WIN_OVERLAP3: passed |
> | | LOCK_EPOCH: passed |
> | | FENCE_EPOCH: passed |
> | | MISC: passed |
> | | POST_EPOCH: passed |
> | | t_win: FAILED 1 |
> | start_timestamp | Tue May 13 04:54:59 2008 |
> | test_name | t_win |
> | variant | 2 |
>

These results are reported to the central OMPI MTT database where we
get e-mail reports each morning.

This particular failure is a known issue; I believe there's a trac
ticket open on it.

--
Jeff Squyres
Cisco Systems

_______________________________________________
mtt-users mailing list
mtt-users_at_[hidden]
http://www.open-mpi.org/mailman/listinfo.cgi/mtt-users




graycol.gif
pic21565.gif
ecblank.gif