Open MPI logo

MTT Users Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2007-09-18 18:36:52


On Sep 18, 2007, at 5:48 PM, Jelena Pjesivac-Grbovic wrote:

> Thanks for the info.
> so I handled the ssl stuff (installed module locally and added "use
> lib <path to CRYPT::SSleys>" to client)
> I am still having problems understanding what is going on.
>
> The system I am running on uses PBS, but I wanted to use it in
> interactive
> mode so I wanted to specify hostfiles.
> I am receiving the following warnings
> ---------
>>> Test run [netpipe]
>>> Running with [ompi-nightly-v1.2] / [1.2.4b1r16141] /
> [ompi/gnu-standard]
> Using MPI Details [ompi] with MPI Install [ompi/gnu-standard]
> Total of 1 tests to run in this section
> Test: NPmpi, np=2, variant=1: Passed
> *** WARNING: Unrecognized resource manager name (hostfile); the only
> permitted names are: "slurm tm loadleveler n1ge none unknown";
> skipped

Doh -- looks like a corner case that I missed (if you use a hostfile,
it should automatically set the resource manager to "none", I would
think). Did you set a value for "resource_manager" in the INI file?
If so, take it out or just set it to none. I'll file a bug to fix
this tomorrow (i.e., if you don't set it at all and are using a
hostlist/hostfile, the Right Thing happens).

For the moment, this is just a warning, so you can ignore it.

> Test: NPmpi, np=2, variant=2: Passed
> *** WARNING: Unrecognized resource manager name (hostfile); the only
> permitted names are: "slurm tm loadleveler n1ge none unknown";
> skipped
> Test: NPmpi, np=2, variant=3: Passed
> ---------
>
> What is causing this warning? (apart from the fact that hostfile is
> not
> known_resource_manager_names in Defaults.pm)
> What does it mean?
> I think I should set resource manager to none - but I am not sure
> where.
>
> I was able to submit trial results for NP to the database, but OSU
> tests
> are timing out.

If you want to see why the OSU tests are timing out, all the stdout/
stderr should be sent to the database and you can view it in the web
reporter. If you're submitting trials, you need to go into the
[preferences] link and enable the checkbox to show trials. You can
also fill in "testbake" in the search description field (or "bakeoff"
if you're running real numbers) in the [advanced] link to help
further delimit your searching in the reporter.

It's usually easiest to search for your organization (utk) for "past
15 minutes" or something like that when you're running a bunch of
little tests. Then you can find the specific test that you're
looking for, look at the stdout, etc.

Make sense?

-- 
Jeff Squyres
Cisco Systems