Open MPI logo

MTT Devel Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all MTT Users mailing list

From: Jeff Squyres \(jsquyres\) (jsquyres_at_[hidden])
Date: 2006-07-18 19:43:20


I would try this manually, without the php script in between.
Specifically:

1. I would modify the .php script to write out a file
2. send a submit through the .php file
3. examine the resulting file and ensure that all the fields match up to
what you think they should be
4. manually submit this file to perfbase and see what happens

That's what I would do.
 

> -----Original Message-----
> From: mtt-users-bounces_at_[hidden]
> [mailto:mtt-users-bounces_at_[hidden]] On Behalf Of Ethan Mallove
> Sent: Tuesday, July 18, 2006 6:33 PM
> To: mtt-users_at_[hidden]
> Subject: [MTT users] perfbase.php not slurping test run data
>
> perfbase.php seems to only populate perfbase with mpi_install
> and test_build
> data. In other words, data correlating to these files is
> getting input to
> perfbase:
>
> inp_mpi_install.xml
> inp_test_build.xml
>
> Data correlating to this file is _not_ getting input to perfbase:
>
> inp_test_run_correctness.xml
>
> I verified this by looking at the perfbase data with pg_dump
> (postgres's
> command-line tool to dump the entire database), which shows
> that there is no
> data for these fields:
>
> test_pass
> test_command
> test_name
> test_np
> test_message
> stderr
> "stdout"
> start_timestamp
> stop_timestamp
>
> The above fields belong to the rundata table. I can see from
> the perfbase
> --debug output there are UPDATEs/INSERTs into the below tables, but no
> UPDATEs/INSERTs into rundata:
>
> run_metadata
> rundata_once
>
> It looks like the data is getting parsed correctly:
>
> E.g.,
>
> #* checking <named_location>: found 'test_name: '
> #* parsing <named_location> 'test_name: '
> content for 'test_name': 'f77_hello'
> *# Processing line:
> test_np: 2
> #* checking <named_location>: found 'test_np: '
> #* parsing <named_location> 'test_np: '
> content for 'test_np': '2'
>
> ... [snip] ...
>
> And there are no error messages from perfbase. Can anyone
> give me a tip on how
> to track down the missing data?
>
> -Ethan
>
> _______________________________________________
> mtt-users mailing list
> mtt-users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/mtt-users
>