Open MPI logo

MTT Devel Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all MTT Devel mailing list

Subject: Re: [MTT devel] Some MTT Reporter woes (Detail view)
From: Josh Hursey (jjhursey_at_[hidden])
Date: 2011-09-11 16:52:49


The detail view issue has been fixed in r1493. See the commit message
for details.

No data was lost. It was just that the query was not selecting all of
the fields that it needed.

Let me know if you see any other issues.

-- Josh

On Fri, Sep 9, 2011 at 2:32 PM, Josh Hursey <jjhursey_at_[hidden]> wrote:
> Terry mentioned a bug to me offline. I am posting here so that others
> with the same problem can see the eventual followup.
>
>
> In the detail view the 'network' and 'command' lines are incorrect:
>  http://www.open-mpi.org/mtt/index.php?do_redir=2009
>
> The 'command' line is blank. So that either means that the Reporter
> SELECT query is not getting the correct data, or that the data was
> never stored. So I'll have to dig into this.
>
> The 'network' line is a number. I suspect that this is the network row
> id, instead of the string values. I think the reporter is not
> activating the translation function properly.
>
> I have also noticed some errors in the log in which the Reporter
> SELECT query is malformed. I'll take a look at how that might have
> occurred while I'm at it.
>
>
> I do not think that these are related to the recent Summary updates
> (since the commands above do not use the tables). I'll try to take a
> look at these issues over the weekend, and post back when I have
> resolved things (or have more information).
>
> -- Josh
>
>
> --
> Joshua Hursey
> Postdoctoral Research Associate
> Oak Ridge National Laboratory
> http://users.nccs.gov/~jjhursey
>

-- 
Joshua Hursey
Postdoctoral Research Associate
Oak Ridge National Laboratory
http://users.nccs.gov/~jjhursey