Open MPI logo

MTT Devel Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all MTT Devel mailing list

From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2007-10-03 03:04:03


On Oct 3, 2007, at 4:12 AM, Mohamad Chaarawi wrote:

> yea im doing that, but not for the already installed libraries..
> that's
> the problem..

Ah - are you saying that we should add these kinds of fields for the
already-installed plugin:

>> mpich2_additional_wrapper_ldflags = -L/opt/slurm/current/lib
>> mpich2_additional_wrapper_libs = -lpmi

If so, I'm not sure we can -- these fields take advantage of the fact
that we know it's MPICH/MVAPICH and know exactly which bits to
twiddle in their script-based wrapper compilers. We can't assume
that an already-installed MPI will have a script-based wrapper
compiler that is exactly like MPICH's wrapper compilers. :-(

Can you not use the already-installed MVAPICH and instead always
install it? I.e., is there a reason you're trying to use an already-
installed MVAPICH?

-- 
Jeff Squyres
Cisco Systems