Open MPI logo

Hardware Locality Users' Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Users mailing list

Subject: Re: [hwloc-users] BGQ question.
From: Biddiscombe, John A. (biddisco_at_[hidden])
Date: 2014-03-25 10:34:18


Just an update to confim I'm doing it all wrong

If I compile on the login node, but run lstopo on the ION, I get this (wrong, below)

if I set export HWLOC_FORCE_BGQ=1 and run on the ION, I get the old message ...
        Topology became empty, aborting!
        Aborted (core dumped)

JB

*** Found unexpected uname sysname `Linux' machine `ppc64', disabling BGQ backend.
*** Set HWLOC_FORCE_BGQ=1 in the environment to enforce the BGQ backend.
Machine
  PU L#0 (P#0)
  PU L#1 (P#1)
  PU L#2 (P#2)
  PU L#3 (P#3)
  PU L#4 (P#4)
  PU L#5 (P#5)
  PU L#6 (P#6)
  PU L#7 (P#7)
  PU L#8 (P#8)
  PU L#9 (P#9)
  PU L#10 (P#10)
  PU L#11 (P#11)
  PU L#12 (P#12)
  PU L#13 (P#13)
  PU L#14 (P#14)
  PU L#15 (P#15)
  PU L#16 (P#16)
  PU L#17 (P#17)
  PU L#18 (P#18)
  PU L#19 (P#19)
  PU L#20 (P#20)
  PU L#21 (P#21)
  PU L#22 (P#22)
  PU L#23 (P#23)
  PU L#24 (P#24)
  PU L#25 (P#25)
  PU L#26 (P#26)
  PU L#27 (P#27)
  PU L#28 (P#28)
  PU L#29 (P#29)
  PU L#30 (P#30)
  PU L#31 (P#31)
  PU L#32 (P#32)
  PU L#33 (P#33)
  PU L#34 (P#34)
  PU L#35 (P#35)
  PU L#36 (P#36)
  PU L#37 (P#37)
  PU L#38 (P#38)
  PU L#39 (P#39)
  PU L#40 (P#40)
  PU L#41 (P#41)
  PU L#42 (P#42)
  PU L#43 (P#43)
  PU L#44 (P#44)
  PU L#45 (P#45)
  PU L#46 (P#46)
  PU L#47 (P#47)
  PU L#48 (P#48)
  PU L#49 (P#49)
  PU L#50 (P#50)
  PU L#51 (P#51)
  PU L#52 (P#52)
  PU L#53 (P#53)
  PU L#54 (P#54)
  PU L#55 (P#55)
  PU L#56 (P#56)
  PU L#57 (P#57)
  PU L#58 (P#58)
  PU L#59 (P#59)