Open MPI logo

Hardware Locality Users' Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [hwloc-users] Having trouble getting CPU Model string on Windows 7 x64
From: Brice Goglin (Brice.Goglin_at_[hidden])
Date: 2014-01-28 02:10:13


The CPUModel attribute should be only in Socket or machine/root objects.
At least, that's what I documented and what I seem to see in the code.
Did you actually see any other place?

So it may just mean that the CPUModel is not available on your machine?
Or maybe the code below is buggy somehow? Does lstopo -v on Windows show
a CPUModel attribute? It does in a 32bits binary running on my Win7
64bits, but doesn't seem to find anything when running the 64bits
binary. I don't remember well if there was a specific Windows 64bits
issue in the cpuid code in the x86 backend.


Le 28/01/2014 01:59, Robin Scher a écrit :
> Hi again.
> I'm trying to use hwloc 1.8 on Windows, Linux and Mac to get the CPU model string (e.g., "Intel(R) Core(TM) i7-3520M CPU @ 2.90GHz"). Since hwloc on different platforms seem to stash this in different objects, I'm using code like this:
> String name;
> hwloc_obj_type_t objs[] = {
> for( size_t index = 0; index < (sizeof( objs ) / sizeof( hwloc_obj_type_t )) && name.Empty(); ++index )
> {
> hwloc_obj_t obj = hwloc_get_obj_by_type( topology, objs[ index ], 0 );
> if( !obj ) continue;
> const char *str = hwloc_obj_get_info_by_name( obj, "CPUModel" );
> if( str ) name = String( str ).Trim();
> }
> On Mac, it works (found string at HWLOC_OBJ_MACHINE), and on Linux it works (found string at HWLOC_OBJ_SOCKET), but on Windows x64, none of these find the string. They all return a NULL pointer.
> Am I missing something? I tried a few other of the object types, but didn't find it with them either (I actually tried looping through all integer values between 0 and HWLOC_OBJ_TYPE_MAX and it didn't appear in any of them).
> Thank you for any help you can provide.
> -robin
> Robin Scher
> robin_at_[hidden]
> +1 (213) 448-0443
> _______________________________________________
> hwloc-users mailing list
> hwloc-users_at_[hidden]