Open MPI logo

Hardware Locality Users' Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Users mailing list

Subject: Re: [hwloc-users] [windows] build from source using visual studio
From: Brice Goglin (Brice.Goglin_at_[hidden])
Date: 2014-01-06 15:09:59


I've been working on adding msvc/cmake support last year (pushed some
msvc-related fixes that are at least in v1.7 and later) but I stopped at
some point because there was not much interest for it, and because it's
not easy to do some automatic testing.

I am not sure what you mean with windows 6.x and x64, but last time I
checked things seemed to work fine on Windows 7 64bits at least. What
symbols are we using that are not not available anymore? When did they
disappear?

Brice

Le 06/01/2014 20:59, Eloi Gaudry a écrit :
>
> Hi,
>
>
>
> I was wondering if you could add Visual Studio support to build hwloc
> from source.
>
> Some open source projects (libpng for instance) for instance
> distribute a "contrib" folder in the sources where every exotic
> platforms get their makefiles-like available.
>
> I begun to write vcxproj (for Visual Studio 2010 and 2012) a file ago,
> but I failed at creating the right autogenerated file used for configure.
>
>
>
> I'm very much interested in building hwloc from source to tune what
> hwloc relies on to work. For instance, version-1.7.2 has a strong
> dependency on some symbols available on Windows 6.x only. This means
> that Windows x64 is not supported.
>
>
>
> Regards,
>
> Eloi
>
>
>
> _______________________________________________
> hwloc-users mailing list
> hwloc-users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/hwloc-users