Open MPI logo

Hardware Locality Users' Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [hwloc-users] receive 0x0 from hwloc_cuda_get_device_cpuset
From: Brice Goglin (Brice.Goglin_at_[hidden])
Date: 2012-02-21 09:48:38


Le 21/02/2012 15:42, Albert Solernou a écrit :
> Hi,
> I have several questions in order to fix this issue from the machine
> side.
>
> 1) I realised that on this machine neither libcpuset nor cpuset-utils
> are installed. Could this be related to the problem?

No, Linux "cpuset" are very different from hwloc "cpuset" and "bitmap"
unfortunately. The former is about reducing the available resources in
the machine so that processes cannot use the entire CPUs for instance.
hwloc detects this feature but it doesn't need libcpuset to do so.
Things just work :)

> 2) Could you specify any BIOS parameter we could tune up

You can look for PCI affinity or PCI NUMA maybe. But I don't think
you'll find anything because your machine isn't NUMA anyway. I/O
affinity don't matter on this machine, there's no reason to
enable/disable it in this BIOS.

> 3) Could this issue be related to the linux kernel?

I think the kernel has been properly detecting this kind of affinity
from the BIOS for a very long time. At least 2.6.18 but likely way earlier.

You should just forget about this problem and use hwloc 1.4.1rc1
(released today, already on the web, to be announced soon, once windows
zips are ready). It contains the workaround for your problem.

Brice