Open MPI logo

Hardware Locality Users' Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [hwloc-users] Compiling hwloc into a static library on Windows and Linux
From: Andrew Helwer (Andrew.Helwer_at_[hidden])
Date: 2012-01-13 12:09:52


> I tried linking to the .lib file in the 64-bit release. I get only unresolved external symbol errors.

Ah right, I keep getting confused over that.

> You can perhaps try to rename it into a .lib file and give that to VS.

Didn't work.

> -----Original Message-----
> From: hwloc-users-bounces_at_[hidden] [mailto:hwloc-users-
> bounces_at_[hidden]] On Behalf Of Samuel Thibault
> Sent: Thursday, January 12, 2012 6:05 PM
> To: Hardware locality user list
> Subject: Re: [hwloc-users] Compiling hwloc into a static library on
> Windows and Linux
>
> Samuel Thibault, le Fri 13 Jan 2012 02:01:12 +0100, a écrit :
> > Andrew Helwer, le Fri 13 Jan 2012 01:51:15 +0100, a écrit :
> > > I'm not sure I understand. Can you link to .a files with VS?
> >
> > I don't know, but what's sure is that .a files are static libraries
> in
> > mingw.
>
> You can perhaps try to rename it into a .lib file and give that to VS.
>
> Samuel
> _______________________________________________
> hwloc-users mailing list
> hwloc-users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/hwloc-users