Open MPI logo

Hardware Locality Users' Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [hwloc-users] hwloc v1.2.1rc1 test on AIX
From: Brice Goglin (Brice.Goglin_at_[hidden])
Date: 2011-08-03 05:29:15


Le 03/08/2011 09:35, Hendryk Bockelmann a écrit :
> Hello Samuel,
>
> installation of hwloc-1.2.1rc1r3571.tar.gz was no problem on AIX6.1

Thanks for testing!

> Report of lstopo for one POWER6 node given:
>
> Machine + L1 L#0 (64KB)
> NUMANode L#0 (P#0)
> L1 L#0 (64KB)
> L2 L#0 (4096KB) + L1 L#0 (64KB) + Core L#0
> PU L#0 (P#0)
> PU L#1 (P#1)
> L2 L#1 (4096KB) + L1 L#1 (64KB) + Core L#1
> PU L#2 (P#2)
> PU L#3 (P#3)
> L1 L#1 (64KB)
> L2 L#2 (4096KB) + L1 L#2 (64KB) + Core L#2
> PU L#4 (P#4)
> PU L#5 (P#5)
> L2 L#3 (4096KB) + L1 L#3 (64KB) + Core L#3
> PU L#6 (P#6)
> PU L#7 (P#7)
> ...
>
> There seems to be two little failures:

Are these new failures ? Did 1.2 work fine ?

> i/ each core has 128kB L1-cache (64kB data and 64kB instruction)

We only report data (and unified caches) so I assume the instruction L1
is ignored on purpose.

> ii/ the shared L3-cache of one POWER6 chip, i.e. of two cores, is 32MB
> - here it is shown as "L1 L#0 (64KB)"

Can you send the output of lstopo after reconfiguring with
--enable-debug, it's not easy to understand what's going on here.

Thanks
Brice