Open MPI logo

Hardware Locality Users' Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Users mailing list

Subject: [hwloc-users] hwloc 1.2 compilation problems
From: cs_at_[hidden]
Date: 2011-06-09 17:32:05


        I wonder whether anyone could speak about exactly what
versions of the supporting operating systems we should expect to
work, particularly specifics about compilation requirements and
instructions.
        I've been trying to build hwloc-1.2 on some of our old
AIX systems (5.2, 5.3, 6.1), without success in all cases. I've
tried both the default configuration (which selected gcc, but could
not complete the configure step) and using CC=/usr/vac/bin/cc (configure
did complete but the make soon found fault with lines in lstopo-text.c).
I've appended the usual compressed tarballs, but if I've missed
some extant, more detailed instructions (which I also didn't find
searching the mailing list archives), I'd appreciate being told where
to go. :-)

                        Carl