Open MPI logo

Hardware Locality Users' Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Users mailing list

Subject: Re: [hwloc-users] Is OSX a supported platform ?
From: Olivier Cessenat (cessenat_at_[hidden])
Date: 2010-06-06 15:52:34


Hi Samuel,

I made the checkout.
I seem to have too old an autoconf.

I ran autogen.sh as rexplained in README line 70.
<<
$ ./autogen.sh
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal -I ./config --output=aclocal.m4t
autoreconf: `aclocal.m4' is unchanged
autoreconf: configure.ac: tracing
configure.ac:16: error: Autoconf version 2.63 or higher is required
configure.ac:16: the top level
autom4te: /usr/bin/gm4 failed with exit status: 63
autoreconf: configure.ac: not using Libtool
autoreconf: running: /usr/bin/autoconf --force
configure.ac:16: error: Autoconf version 2.63 or higher is required
configure.ac:16: the top level
autom4te: /usr/bin/gm4 failed with exit status: 63
autoreconf: /usr/bin/autoconf failed with exit status: 63
>>
<<
$ autoconf --version
autoconf (GNU Autoconf) 2.59
Written by David J. MacKenzie and Akim Demaille.

Copyright (C) 2003 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is
NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR
PURPOSE.
>>
I'm not sure my technical skills in computer science will allow me to
update the autoconf stuff - as well as it may be preferable to keep an
old but stable system... What do you think ?
Olivier.

Le dimanche 06 juin 2010 à 21:32 +0200, Samuel Thibault a écrit :
> Olivier Cessenat, le Sun 06 Jun 2010 21:24:40 +0200, a écrit :
> > svn checkout from where ?
>
> As announced on the website and in README:
>
> svn checkout http://svn.open-mpi.org/svn/hwloc/trunk
>
> Samuel
> _______________________________________________
> hwloc-users mailing list
> hwloc-users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/hwloc-users