Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: [hwloc-devel] hwloc-1.6.x tainted with GPL?
From: Pavan Balaji (balaji_at_[hidden])
Date: 2013-09-06 10:30:39


Folks,

The mpich-3.0.x series was released with hwloc-1.6.x. One our of partners just brought it to our attention that this version of hwloc has LGPL-2.1 code in src/libltdl.

We are upgrading our code to use hwloc-1.7.x, which doesn't seem to have this problem, but if 1.6.x is still supported, you guys might want to get that fixed in there. Or at least put up a warning on the website about this.

Regards,

 -- Pavan

--
Pavan Balaji
http://www.mcs.anl.gov/~balaji