Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] libpci: GPL
From: Brice Goglin (Brice.Goglin_at_[hidden])
Date: 2013-02-09 10:39:27


Le 09/02/2013 15:50, Jeff Squyres (jsquyres) a écrit :
> On Feb 8, 2013, at 6:08 AM, Brice Goglin <Brice.Goglin_at_[hidden]> wrote:
>
>> Jeff, do you want to put a patch into OMPI 1.7rc7 in the very near
>> future? I mean even before we do a v1.6.2? I still want some testing
>> before we put that into a hwloc release. And with at least one week
>> between rc1 and final, it'll take some time.
>
> In OMPI v1.7, we're using hwloc 1.5.1 (plus a few post-1.5.1 patches, IIRC). I've been staying about 1 generation behind the hwloc current series so that hwloc bugs get shaken out, etc.
>
> Do we have a patch for hwloc 1.5.x?
>

Here's a patch.

To answer you other email: There's no warning anymore once libpci is
enabled. Only a warning when no PCI because we don't enable libpci by
default. The GPL issue is documented in the doxyfile and in configure
--help. If the user passes --enable-libpci without ever looking at what
it means, that's his fault.

Brice