Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] libpci: GPL
From: Jeff Squyres (jsquyres) (jsquyres_at_[hidden])
Date: 2013-02-06 09:06:23

On Feb 5, 2013, at 10:11 PM, Brice Goglin <Brice.Goglin_at_[hidden]> wrote:

> It's a Xorg dependency, so it's available on many platforms and
> prepackaged in many distributions, including darwin if I remember correctly.

I'm thinking that we should actually release a new version for all hwloc versions that defaulted to use libpci -- that's 1.3.x and beyond. :-\

I'll need to update the version that's bundled all versions of OMPI (1.6.x., 1.7.x, trunk), for example.

I'll volunteer to do the configury stuff. I see Brice just made a svn branch; do you want me to commit the updates there? Or did you want to just do it all?

Are we removing the possibility of using libpci?

Jeff Squyres
For corporate legal information go to: