Le 25/09/2012 10:17, Brice Goglin a écrit :
> Le 25/09/2012 09:49, Samuel Thibault a écrit :
>> One thing which can be confusing for the user is that core_linux goes
>> to the core os list while core_libpci goes to the additional list. It
>> would probably be better to use a different class name. I actually don't
>> currently understand what classes are used for.
> The class name was initially used to distinguish between normal (core)
> plugins and xml backends. It may be possible to completely remove it now
> that component struct have a type, I'll check.
> We have the "core_xml" component (generic xml support) and "xml_libxml"
> + "xml_nolibxml" backends behind that. I am fine with removing the
> "core_" prefix,
I am also going to add a hwloc_ prefix to plugin filenames because we
obviously can't create a libpci.so (libtool even warns about this).
XML backends could be hwlocxml_ (not hwloc_xml_) to make it clear that
they are not normal hwloc_ plugins.