Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] merging plugins?
From: Brice Goglin (Brice.Goglin_at_[hidden])
Date: 2012-09-25 03:42:00


Le 25/09/2012 09:26, Brice Goglin a écrit :
> On most OS, we already have multiple "core os" components, one native
> (linux, ...) with priority 10 and the "noos" one with priority 0. If
> nothing forces a specific component in the list (no env variable, no
> set_xml, ...), we instantiate the first one (higher priority), which is
> the native component when it exists.
>

Small fix: "noos" is actually currently named "none".
I just checked that your code successfully uses it with HWLOC_PLUGINS=none
But I now see that "none" is bad name here so I will change it back to
"noos"

Brice