Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [hwloc-devel] [hwloc-svn] svn:hwloc r4815 - branches/components/src
From: Brice Goglin (brice.goglin_at_[hidden])
Date: 2012-09-06 10:48:58


He's building with cmake instead of libtool. Maybe it's a libtool-only issue.
Btw, I still need to look at his hwloc cmake patches.
Brice

Samuel Thibault <samuel.thibault_at_[hidden]> a écrit :

>Jeff Squyres, le Thu 06 Sep 2012 15:46:29 +0200, a écrit :
>> On Sep 6, 2012, at 7:46 AM, Jeff Squyres wrote:
>> > (sorry; I forgot to ping Shiqing yesterday -- I just did so now to
>get a confirmation of what you found)
>>
>>
>> Shiqing confirms that DSOs are disabled by default on Windows.
>However, he says that they do actually work if you enable them.
>
>Mmm, I wonder how. Actually now I remember, it wasn't darwin which was
>posing problem with no -no-undefined, but windows, which requires it
>for
>shared libraries, and thus requiring -lhwloc.
>
>Samuel
>_______________________________________________
>hwloc-devel mailing list
>hwloc-devel_at_[hidden]
>http://www.open-mpi.org/mailman/listinfo.cgi/hwloc-devel