Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] merging the valarray branch (with a better name)
From: Brice Goglin (brice.goglin_at_[hidden])
Date: 2012-08-24 19:22:18


>If so, there's no need for topology-wide
>hwloc_set_topology_userdata_blob_callback(), the application gives the
>right callbacks when it adds the (key,data) pair.

Forget about this last sentence. We cannot set per object import callback in advance since objects are not imported yet. The import callback has to be topology-wide. It'll be able to look at the object attributes if different kinds of blobs may have been exported for different objects

Brice