Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] merging the valarray branch (with a better name)
From: Brice Goglin (Brice.Goglin_at_[hidden])
Date: 2012-08-24 09:44:41


Le 24/08/2012 15:20, Jeff Squyres a écrit :
> I was thinking more like:
>
> struct annotation {
> char *name;
> int array_len;
> enum { INT, LONG, FLOAT, DOUBLE } value_type;
> union {
> int *i_values;
> long *l_values;
> float *f_values;
> double *d_values;
> /* other types if you want them */

That could work yes.

> unsigned *indexes; /* I'm not sure what this is for? */
>

It tells that values[x] is the value for object/stuff whose number is
indexes[x]
For sparse numbering, things like that.

Brice